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Introduction

In October 2012, subject matter experts from several federal agencies developed an Accessible Electronic Document Community of Practice (AED COP) with the goal of improving accessible content, advancing the field of accessibility, and creating accessible artifacts reusable across many agencies.

Federal agencies and other institutions create millions of documents each year. Making documents accessible is important so that individuals with disabilities can access information. Individuals with disabilities may include, but are not limited to: Blind or Low Vision, Deaf or Hard of Hearing, Physical Disability and Intellectual Disability.
Assistive technology (AT) is used by individuals to help them understand electronic information. For example, screen readers or text-to-speech software is one tool available and assists individuals who are blind, have low vision, or a learning disability. This technology interprets words on the page and translates them to a computerized voice that reads the information. Accessible documents work in partnership with assistive technology to ensure individuals with disabilities have access to information. 
As you create your MS Excel document, it might be helpful to think about the concept of comparable access. When you adhere to the following accessibility requirements, you are creating a document that allows individuals with disabilities 1) to access the important information that you are creating and 2) to gain access to information in a comparable way as their non-disabled peers.
This document contains the minimum steps required to make an electronic MS Excel 2010 document Section 508 accessible and acceptable for posting to a website. This information includes how to author and how to check your work.

The current version 1.0 is approved for distribution by the AED COP. Please send review comments and feedback to Holly.Anderson@ed.gov.
This document covers the MS Excel 2010 (.docx) fromat and is divided into 5 categories:

· Document Formatting
· Text Formatting
· Object Formatting
· Color Formatting
· Miscellaneous
This document does NOT cover:

· An MS Excel 2010 document with macros (.xlsm).
· An MS Excel 2010 document with forms enabled (see the Forms section).
· An MS Excel 2010 document with restrictions enabled.
Document Formatting

1. Save as an excel Workbook (.xlsX) with a descriptive filename
A descriptive filename that identifies the document or its purpose helps everyone (including people with disabilities) locate, open, and switch between documents. In addition, the document must be in a “.xlsx” format; the authoring and testing instructions in each section are only for MS Excel 2010 documents. 
Author Accessibly

Go to File>Save As
1) Save as a Excel Workbook (.xlsx).

2) Save your document with a descriptive filename.
Figure 1: Example of save as Excel Workbook (.xlsx) and descriptive filename 
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Check Your Work

Look at the file in Windows Explorer OR the title bar in MS Excel.

1) Check that the file type is an Excel 2010 Workbook (.xlsx).
2) Check that the filename is descriptive and identifies the document or its purpose. 
Table 1: Examples of nondescriptive and descriptive filenames

	Nondescriptive Filename
	Descriptive Filename

	Untitled.xls
	OMBReport387_2102014_v2.xlsx

	Book1.xls
	Chapter6FY2016Justification.xlsx

	Application.xlsm
	2015Security_Training.xlsx


 Text Formatting
2. Use built-in features to organize content
Create a structure that screen readers and AT can use to read information in the correct order (left to right then top to bottom). 

Author Accessibly 
To create a document with organized content:

1. Create your spreadsheet with an organized or logical reading order.  
2. Make sure you can create a layout that you can navigate only using your keyboard with the up, down, right, left arrow keys.
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Check Your Work

To check your work, you:

1. Examine each sheet to ensure you have a visual and/or logical reading order.
2. Navigate the sheet with the up, down, right, left arrow keys to ensure that it matches the a visual/logical reading order.
3. Create unambiguous names for links
It is important to provide unambiguous names or context for links that describe the destination, function or purpose so that AT can correctly identify information. For example, if you have several links and you name them all “click here,” then AT will not be able to convey to individuals with disabilities information that distinguishes distinct links.
Author Accessibly

Ensure that the destination, purpose or function is described in surrounding text 
OR
Go to Insert>Hyperlink
To set a hyperlink name, you:
1) Type an unambiguous name in your document that describes the destination, function, and/or purpose. 
2) Select the text in your document that you want to be a hyperlink (this text will show in “Text to Display”).

3) Go to Insert>Hyperlink>LinkTo
a. If “Existing File or Web Page,” type the accurate URL in Address.

b. If “Place in this Document,” click on the appropriate line in “Select a Place in this Document.”

c. If “Create a New Document,” type in the document name in “Name of New Document.”

d. If “Email Address,” type a valid email address in “E-mail address.”
Check Your Work

To check your work, you:
1) Check to ensure your link has an unambiguous name that describes the destination, function, and/or purpose OR that this is determinable within context. For example:
a. Uniquely Named Link:
…additional details are available on OPM.gov.

b. Links Determinable within Context: 
Further details are listed in the Company Annual Report.
c. Ambiguous Links Not Determinable Within Context:
Information about each topic is available click here / click here.
Object Formatting

4. Duplicate vital information in Headers, Footers and Watermarks
Screen readers do not automatically read information in headers/footers and watermarks. Therefore, vital information (such as Respond by X Date, CONFIDENTIAL, or Do Not Distribute) must also be duplicated at or near the start of the main content area.
Author Accessibly
Duplicate vital information in the Header/Footer or Watermark at or near the start of the related information (such as the beginning of your document or the start of a section).
Figure 2: Example of a header duplicated at the start of the related information
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Check Your Work

To check your work, you:

1) Switch to page layout view (View > Page Layout).
2) Look for vital information in headers, footers and watermarks.
3) Go to the start or near the start of the related information and ensure you have duplicated vital information (such as Respond by X Date, CONFIDENTIAL, or Do Not Distribute).
5. Use built-in features to create data tables
Data tables are those tables where the information in a cell requires information from a row and/or column header to adequately describe the cell's content.  When you create a data table you must:
1) Insert tables. You cannot make images of tables accessible.
2) Keep data tables simple (use one row of column headers and no merged or split cells).

3) Identify the header row and/or column.

If you need to create complex data tables (data tables with more than one header row, more than one header column, and/or merged or split cells), then you must convert the document to an accessible format. Complex data tables cannot be made accessible in MS Word 2010.

Author Accessibly 

To create a data table you:
1) Go to Insert > Tables

2) Insert the data into your worksheet.
3) Do not merge or split cells.

4) Only type headers into the first row and/or column and identify the header row and/or column by opening the Name Manager (Alt + M, N). Check that each data table corresponds to a Name and that the Name and Range follow the following formats:

a. For data tables with one row of column headers:
“ColumnTitle[Name]..D10” and “=Sheet1!$A$1”, where A1 is substituted for the first cell of the table and D10 is substituted for the last cell of the table.
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b. For data tables with one column of row headers:
“RowTitle[Name]..D10” and “=Sheet1!$A$1”, where A1 is substituted for the first cell of the table and D10 is substituted for the last cell of the table.
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c. For data tables with both one row and one column of headers:
“Title[Name]..D10” and “=Sheet1!$A$1”, where A1 is substituted for the first cell of the table and D10 is substituted for the last cell of the table.
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Check Your Work

To check your work, you:

1) Click on your table and make sure it’s not a picture. (If the Picture Tools Tab shows in the Ribbon, then it is a picture).
2) Verify that you do not have any multi-levlel headings or any merged or split cells.
3) Verify that you have identified the header row and/or column.  Open the Name Manager (Alt + M, N). Check that each data table corresponds to a Name and that the Name and Range follow the following formats:

•
For data tables with one row of column headers:

“ColumnTitle[Name]..D10” and “=Sheet1!$A$1”, where A1 is substituted for the first cell of the table and D10 is substituted for the last cell of the table.

•
For data tables with one column of row headers:

“RowTitle[Name]..D10” and “=Sheet1!$A$1”, where A1 is substituted for the first cell of the table and D10 is substituted for the last cell of the table.

•
For data tables with both one row and one column of headers:

“Title[Name]..D10” and “=Sheet1!$A$1”, where A1 is substituted for the first cell of the table and D10 is substituted for the last cell of the table.
6. Create accessible images and other Objects
Screen readers cannot infer meaning from images and other objects. Images and other objects include pictures, images of text, images of tables, shapes, icons with hyperlinks, etc. Therefore, you must add descriptive text to images and other objects by putting information in surrounding text or in an appendix. 
Author Accessibly

To add descriptive text to images and other objects put information in surrounding text or in an appendix. 
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Check Your Work

To check your work, you:

1) Check that you have descriptive text in surrounding text or an appendix.
Color Formatting
7. Use color (and other sensory characteristics) plus text to convey meaning
In order to use color and other sensory characteristics (such as size, shape, and location) accessibly, ensure that you do not use color alone to convey meaning. If you do, then individuals with disabilities who are blind, have low vision or are color blind will not have access to comparable information. 

Author Accessibly 

To use color accessibly:

1) Use color and other sensory characteristics (such as size, shape, and location) to convey meaning. 
2) Create text that duplicates the meaning of the color or other sensory characteristic).
Check Your Work

To check your work, you:

1) Find where you have used color and other characteristics.

2) Ensure that you have created text that duplicates the meaning of the color or other sensory characteristics. For example, if you use a layout table to convey status on a project, use text and color to convey meaning.

Table 3: Example of a Status Layout Table Using Color and Text

	Project A
	ON
TIME

	Project B
	AT
RISK

	Project C
	LATE


8. Create the required color contrast
Having a high level of contrast between foreground and background results in more people being able to see and use the content. However, there are standards that are required and listed below:
Table 4: Table with Color Contrast Ratios by Text Size or Type
	Type or Size of Text 

	Contrast Ratio

	Standard
	4.5:1

	Large Text (14 pt bold or 18 pt regular)
	3:1

	Incidental text, text overlaid on images, and logotypes
	Excluded from requirement


Author Accessibly 

Create content with text or images of text that use color or shading with sufficient color contrast.
Check Your Work

1) Execute the color contrast analyzer. Click download (the application can be executed without downloading it onto your computer). 

2) Use the color contrast analyzer to check that you have authored with the correct color contrast ratio. Drag the Foreground eyedropper icon over a sample of your text or image of text. Drag the Background eyedropper icon over a sample of your background color. If the contrast ratio does not pass, then adjust your foreground or background until it does pass.
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Miscellaneous
9. Create accessible embeded files 
If you embed an audio-only, video-only or multimedia file that contains meaningful information into your MS Excel document, you must also provide additional information so that individuals with disabilities have comparable access to the information.
Author Accessibly

Table 5: Table Identifying Type of File and Additional Document Required

	Type of File
	Also include:
	What is this?

	Audio-only 
	Accurate and complete transcript 
	A transcript is a text version of exactly what is being said in the audio-only file.

	Video-only
	Accurate and complete text description
	A description is a text version of what is being shown in a video-only file.

	Multimedia (audio and video)
	Accurate and complete synchronized captions and 
audio descriptions
	Captions are a time-synchronized text version of exactly what is being said and/or a description of the relevant sounds in the multimedia file.
Audio descriptions are time-synchronized descriptions of what is being shown in the multimedia file.


Check Your Work

To check your work, you:

1) Activate the meaningful audio-only, video-only or multimedia file.

2) Compare the corresponding text transcript, text description, or synchronized captions and audio description to ensure it is accurate and complete.

10. Avoid forms in MS Excel 2010
You cannot create an accessible form, suitable for publishing on a website, using MS Word. If you need to create a form, another application may be more appropriate so please contact the AT Team for assistance. The AT Team will analyze your business need and make an appropriate recommendation.
11. Exclude flashing objects
Federal agencies do not typically see flashing objects embedded into MS Word documents. Since flashing objects may be a public safety issue for individuals with photosensitive epilepsy and there is not typically a compelling business need, flashing objects should be excluded. If you feel you do have a compelling business need, please contact the AT Team for assistance in ensuring your object flashes below 3Hz. 
12. Alternative accessible version
Federal agencies have the goal to produce one accessible document for everyone. However, there may be times when this is not feasible. Therefore, it is recommended that you contact the AT Team to ensure an alternative version is necessary as you are still required to create an alternative version that is accessible, up-to-date and has equivalent content.
Section 508 Basic Authoring and Testing Guide - MS Excel 2010
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